top

Package podsecuritypolicy contains code for validating and defaulting the security context of a pod and its containers according to a security policy.

Imports 12 package(s)

  1. k8s.io/kubernetes/pkg/api
  2. k8s.io/kubernetes/pkg/security/podsecuritypolicy/group
  3. k8s.io/kubernetes/pkg/security/podsecuritypolicy/sysctl
  4. k8s.io/kubernetes/pkg/security/podsecuritypolicy/user
  5. k8s.io/kubernetes/pkg/security/podsecuritypolicy/util
  6. k8s.io/kubernetes/pkg/util/validation/field
  7. k8s.io/kubernetes/pkg/apis/extensions
  8. k8s.io/kubernetes/pkg/security/podsecuritypolicy/apparmor
  9. k8s.io/kubernetes/pkg/security/podsecuritypolicy/capabilities
  10. k8s.io/kubernetes/pkg/security/podsecuritypolicy/selinux
  11. k8s.io/kubernetes/pkg/util/maps
  12. k8s.io/kubernetes/pkg/util/errors

Test imports 3 package(s)

  1. k8s.io/kubernetes/pkg/util/diff
  2. github.com/davecgh/go-spew/spew
  3. k8s.io/kubernetes/pkg/security/apparmor