top
(README.md)
# FITS

Field Time Series data.

### Dependencies and Compilation

Dependencies are included in this repo using Go 1.6+ vendoring and govendor.

Run:

```go build && ./fits```

Run all tests (including any in sub dirs):

```go test ./...```

### Database

You will need Postgres 9.x+ and Postgis 2+.  

You can then init the DB and load a small amount of test data with:

```
cd scripts; ./initdb.sh
```

#### Logical Model

The database logical model.

![database logical model](ddl/FITS_Logical_Model.png)

Imports 7 package(s)

  1. github.com/GeoNet/web
  2. github.com/GeoNet/web/api/apidoc
  3. github.com/GeoNet/log/logentries
  4. github.com/lib/pq
  5. github.com/GeoNet/fits/ts
  6. github.com/GeoNet/cfg
  7. github.com/GeoNet/map180

Test imports 1 package(s)

  1. github.com/GeoNet/web/webtest